import re
regex = re.compile(r"(?<=\bcopy\b)[\s\S]*?(?=\s*\bfrom\b)", flags=re.MULTILINE)
test_str = "copy table values from 'a.dat';"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)