$re = '/(?<=\bcopy\b)[\s\S]*?(?=\s*\bfrom\b)/m';
$str = 'copy table values from \'a.dat\';';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;