use strict;
my $str = '"doctype": "Item_attribute_value_customer_name"';
my $regex = qr/_([a-z])/mp;
my $subst = ' $1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";