// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)_([a-z])").unwrap();
let string = "\"doctype\": \"Item_attribute_value_customer_name\"";
let substitution = " $1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}