re = /_([a-z])/m
str = '"doctype": "Item_attribute_value_customer_name"'
subst = ' $1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result