# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\s*\S+\s*\b(\d+(?:[.\/]\d+)+)\b.*?-.*?\b(\S+)\b\s*(\d+)\s*$/$2 $1-$3/gm;t' <<< "GPX 10.802.123/3843 1 - IDENTIFIER 48"