package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*\S+\s*\b(\d+(?:[./]\d+)+)\b.*?-.*?\b(\S+)\b\s*(\d+)\s*$`)
var str = `GPX 10.802.123/3843 1 - IDENTIFIER 48`
var substitution = "$2 $1-$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}