use strict;
my $str = 'GPX 10.802.123/3843 1 - IDENTIFIER 48';
my $regex = qr/^\s*\S+\s*\b(\d+(?:[./]\d+)+)\b.*?-.*?\b(\S+)\b\s*(\d+)\s*$/mp;
my $subst = '$2 $1-$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";