import Foundation
let pattern = #"^\s*\S+\s*\b(\d+(?:[./]\d+)+)\b.*?-.*?\b(\S+)\b\s*(\d+)\s*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"GPX 10.802.123/3843 1 - IDENTIFIER 48"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2 $1-$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)