const regex = /^\s*\S+\s*\b(\d+(?:[./]\d+)+)\b.*?-.*?\b(\S+)\b\s*(\d+)\s*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*\\S+\\s*\\b(\\d+(?:[.\/]\\d+)+)\\b.*?-.*?\\b(\\S+)\\b\\s*(\\d+)\\s*$', 'gm')
const str = `GPX 10.802.123/3843 1 - IDENTIFIER 48`;
const subst = `$2 $1-$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);