re = /^\s*\S+\s*\b(\d+(?:[.\/]\d+)+)\b.*?-.*?\b(\S+)\b\s*(\d+)\s*$/m
str = 'GPX 10.802.123/3843 1 - IDENTIFIER 48'
subst = '$2 $1-$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result