using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=eat_apple_|eat_pear_|eat_orange_)(today|yesterday)";
string input = @"eat_orange_today
eat_pear_today
eat_banana_today
eat_apple_yesterday
eat_strawberry_today";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}