use strict;
my $str = 'eat_orange_today
eat_pear_today
eat_banana_today
eat_apple_yesterday
eat_strawberry_today';
my $regex = qr/(?<=eat_apple_|eat_pear_|eat_orange_)(today|yesterday)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}