const regex = /(?<=eat_apple_|eat_pear_|eat_orange_)(today|yesterday)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=eat_apple_|eat_pear_|eat_orange_)(today|yesterday)', 'gm')
const str = `eat_orange_today
eat_pear_today
eat_banana_today
eat_apple_yesterday
eat_strawberry_today`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}