import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=eat_apple_|eat_pear_|eat_orange_)(today|yesterday)";
final String string = "eat_orange_today\n"
+ "eat_pear_today\n"
+ "eat_banana_today\n"
+ "eat_apple_yesterday\n"
+ "eat_strawberry_today";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}