$re = '/(?<=eat_apple_|eat_pear_|eat_orange_)(today|yesterday)/m';
$str = 'eat_orange_today
eat_pear_today
eat_banana_today
eat_apple_yesterday
eat_strawberry_today';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);