re = /(?<=eat_apple_|eat_pear_|eat_orange_)(today|yesterday)/m
str = 'eat_orange_today
eat_pear_today
eat_banana_today
eat_apple_yesterday
eat_strawberry_today'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end