#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([^;]+);\s*$"
Local $sString = "Test;Something" & @CRLF & _
"should be correct;" & @CRLF & _
"this one could be correct with some spaces after; " & @CRLF & _
"Ok;" & @CRLF & _
"Not ok; --nothing to do here" & @CRLF & _
"Is this ok without the semicolon?" & @CRLF & _
"^-- Probably not;" & @CRLF & _
";" & @CRLF & _
"^-- What about a line just with a semicolon?;" & @CRLF & _
"This char ";" is not allowed!;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")