use strict;
my $str = 'Test;Something
should be correct;
this one could be correct with some spaces after;
Ok;
Not ok; --nothing to do here
Is this ok without the semicolon?
^-- Probably not;
;
^-- What about a line just with a semicolon?;
This char ";" is not allowed!;';
my $regex = qr/^([^;]+);\s*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}