using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^;]+);\s*$";
string input = @"Test;Something
should be correct;
this one could be correct with some spaces after;
Ok;
Not ok; --nothing to do here
Is this ok without the semicolon?
^-- Probably not;
;
^-- What about a line just with a semicolon?;
This char "";"" is not allowed!;";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}