re = /^([^;]+);\s*$/m
str = 'Test;Something
should be correct;
this one could be correct with some spaces after;
Ok;
Not ok; --nothing to do here
Is this ok without the semicolon?
^-- Probably not;
;
^-- What about a line just with a semicolon?;
This char ";" is not allowed!;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end