$re = '/^([^;]+);\s*$/m';
$str = 'Test;Something
should be correct;
this one could be correct with some spaces after;
Ok;
Not ok; --nothing to do here
Is this ok without the semicolon?
^-- Probably not;
;
^-- What about a line just with a semicolon?;
This char ";" is not allowed!;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);