import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^;]+);\\s*$";
final String string = "Test;Something\n"
+ "should be correct;\n"
+ "this one could be correct with some spaces after; \n"
+ "Ok;\n"
+ "Not ok; --nothing to do here\n"
+ "Is this ok without the semicolon?\n"
+ "^-- Probably not;\n"
+ ";\n"
+ "^-- What about a line just with a semicolon?;\n"
+ "This char \";\" is not allowed!;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}