#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)^(?!.*\bvpn\b).*\budp\b.*$"
Local $sString = " /root/sumcommand -x -y udp " & @CRLF & _
" MATCH " & @CRLF & _
"" & @CRLF & _
" /root/sumcommand VPN udp 12 4 2" & @CRLF & _
" NO MATCH" & @CRLF & _
"" & @CRLF & _
" /root/sumcommand -x -y udp VPN 2 4 52" & @CRLF & _
" NO MATCH" & @CRLF & _
"" & @CRLF & _
" /root/sumcommand udp ocean tools 1 5 2" & @CRLF & _
" MATCH"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")