using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)^(?!.*\bvpn\b).*\budp\b.*$";
string input = @" /root/sumcommand -x -y udp
MATCH
/root/sumcommand VPN udp 12 4 2
NO MATCH
/root/sumcommand -x -y udp VPN 2 4 52
NO MATCH
/root/sumcommand udp ocean tools 1 5 2
MATCH";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}