re = /(?i)^(?!.*\bvpn\b).*\budp\b.*$/m
str = ' /root/sumcommand -x -y udp
MATCH
/root/sumcommand VPN udp 12 4 2
NO MATCH
/root/sumcommand -x -y udp VPN 2 4 52
NO MATCH
/root/sumcommand udp ocean tools 1 5 2
MATCH'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end