use strict;
my $str = ' /root/sumcommand -x -y udp
MATCH
/root/sumcommand VPN udp 12 4 2
NO MATCH
/root/sumcommand -x -y udp VPN 2 4 52
NO MATCH
/root/sumcommand udp ocean tools 1 5 2
MATCH';
my $regex = qr/(?i)^(?!.*\bvpn\b).*\budp\b.*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}