import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)^(?!.*\\bvpn\\b).*\\budp\\b.*$";
final String string = " /root/sumcommand -x -y udp \n"
+ " MATCH \n\n"
+ " /root/sumcommand VPN udp 12 4 2\n"
+ " NO MATCH\n\n"
+ " /root/sumcommand -x -y udp VPN 2 4 52\n"
+ " NO MATCH\n\n"
+ " /root/sumcommand udp ocean tools 1 5 2\n"
+ " MATCH";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}