#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i) (?<!\S)the(?!\S)" & @CRLF & _
""
Local $sString = "the some the text [more text in parentheses] and there the the there " & @CRLF & _
"some not in parentheses [more text in the parentheses] and some not in parentheses some text" & @CRLF & _
"the [more text in parentheses]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")