using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" (?<!\S)the(?!\S)
";
string input = @"the some the text [more text in parentheses] and there the the there
some not in parentheses [more text in the parentheses] and some not in parentheses some text
the [more text in parentheses]";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}