use strict;
my $str = 'the some the text [more text in parentheses] and there the the there
some not in parentheses [more text in the parentheses] and some not in parentheses some text
the [more text in parentheses]';
my $regex = qr/ (?<!\S)the(?!\S)
/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}