$re = '/ (?<!\S)the(?!\S)
/i';
$str = 'the some the text [more text in parentheses] and there the the there
some not in parentheses [more text in the parentheses] and some not in parentheses some text
the [more text in parentheses]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);