const regex = / (?<!\S)the(?!\S)
/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(' (?<!\\S)the(?!\\S)
', 'ig')
const str = `the some the text [more text in parentheses] and there the the there
some not in parentheses [more text in the parentheses] and some not in parentheses some text
the [more text in parentheses]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}