re = / (?<!\S)the(?!\S)
/i
str = 'the some the text [more text in parentheses] and there the the there
some not in parentheses [more text in the parentheses] and some not in parentheses some text
the [more text in parentheses]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end