# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[(\d+)\]$/$1/;t' <<< "attachments[23543][non-users][33]"