re = /\[(\d+)\]$/
str = 'attachments[23543][non-users][33]'
subst = '$1'
result = str.sub(re, subst)
# Print the result of the substitution
puts result