using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(\d+)\]$";
string substitution = @"$1";
string input = @"attachments[23543][non-users][33]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}