# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?s)(?>\\/\*(?>(?:(?>[^*]+)|\*(?!\\/))*)\*\\/)//;t' <<< "/* 34:
*
*
*
*/
/*
* JD-Core Version: 0.7.0.1
*/
test
test
test
/* another comment */
test
test
test
/*
another comment with
new
lines
*/"