import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)(?>\\/\\*(?>(?:(?>[^*]+)|\\*(?!\\/))*)\\*\\/)";
final String string = "/* 34: \n"
+ "*\n"
+ "*\n"
+ "*\n"
+ " */\n\n\n"
+ "/*\n\n"
+ " * JD-Core Version: 0.7.0.1\n\n"
+ "*/\n\n"
+ "test\n"
+ "test\n"
+ "test\n\n"
+ "/* another comment */\n\n"
+ "test\n"
+ "test\n"
+ "test\n\n"
+ "/*\n"
+ "another comment with\n"
+ "new\n"
+ "lines\n"
+ "*/";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}