const regex = /(?s)(?>\/\*(?>(?:(?>[^*]+)|\*(?!\/))*)\*\/)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)(?>\\\/\\*(?>(?:(?>[^*]+)|\\*(?!\\\/))*)\\*\\\/)', '')
const str = `/* 34:
*
*
*
*/
/*
* JD-Core Version: 0.7.0.1
*/
test
test
test
/* another comment */
test
test
test
/*
another comment with
new
lines
*/`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);