$re = '/(?s)(?>\/\*(?>(?:(?>[^*]+)|\*(?!\/))*)\*\/)/';
$str = '/* 34:
*
*
*
*/
/*
* JD-Core Version: 0.7.0.1
*/
test
test
test
/* another comment */
test
test
test
/*
another comment with
new
lines
*/';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;