#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^\s*function\s+(.*\s)+?\})"
Local $sString = "function foo()" & @CRLF & _
" public" & @CRLF & _
" returns (bool)" & @CRLF & _
"{" & @CRLF & _
" ... Function Contents ..." & @CRLF & _
"if { ... }" & @CRLF & _
"abcd" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"/**" & @CRLF & _
" * Some information about this functions... " & @CRLF & _
" */" & @CRLF & _
" function bar(type v1, type v2)" & @CRLF & _
" public" & @CRLF & _
" returns (bool)" & @CRLF & _
"{" & @CRLF & _
" ... Function Contents ..." & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")