$re = '/(^\s*function\s+(.*\s)+?\})/m';
$str = 'function foo()
public
returns (bool)
{
... Function Contents ...
if { ... }
abcd
}
/**
* Some information about this functions...
*/
function bar(type v1, type v2)
public
returns (bool)
{
... Function Contents ...
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);