// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^\s*function\s+(.*\s)+?\})").unwrap();
let string = "function foo()
public
returns (bool)
{
... Function Contents ...
if { ... }
abcd
}
/**
* Some information about this functions...
*/
function bar(type v1, type v2)
public
returns (bool)
{
... Function Contents ...
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}