import re
regex = re.compile(r"(^\s*function\s+(.*\s)+?\})", flags=re.MULTILINE)
test_str = ("function foo()\n"
" public\n"
" returns (bool)\n"
"{\n"
" ... Function Contents ...\n"
"if { ... }\n"
"abcd\n"
"}\n\n"
"/**\n"
" * Some information about this functions... \n"
" */\n"
" function bar(type v1, type v2)\n"
" public\n"
" returns (bool)\n"
"{\n"
" ... Function Contents ...\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")