re = /(^\s*function\s+(.*\s)+?\})/m
str = 'function foo()
public
returns (bool)
{
... Function Contents ...
if { ... }
abcd
}
/**
* Some information about this functions...
*/
function bar(type v1, type v2)
public
returns (bool)
{
... Function Contents ...
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end