import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^\\s*function\\s+(.*\\s)+?\\})";
final String string = "function foo()\n"
+ " public\n"
+ " returns (bool)\n"
+ "{\n"
+ " ... Function Contents ...\n"
+ "if { ... }\n"
+ "abcd\n"
+ "}\n\n"
+ "/**\n"
+ " * Some information about this functions... \n"
+ " */\n"
+ " function bar(type v1, type v2)\n"
+ " public\n"
+ " returns (bool)\n"
+ "{\n"
+ " ... Function Contents ...\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}