using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\n\r\s]*#{ListStart:ExtDocuments}[\n\r]([\w\n\r\s\<\>\#\{\}\/\-]*)#{ListEnd:ExtDocuments}[\n\r\s]*";
string input = @"<html>
<head>
<title>#{Subject}</title>
</head>
<body>
<div>StringTest: #{String}</div>
<div>IntTest: #{Int}</div>
<div>IntTest: #{INT}</div>
<div>IntTest: #{int}</div>
<div>IntTest: #{iNt}</div>
#{ListStart:Documents}
<div>#{Value}</div>
#{ListEnd:Documents}
#{ListStart:ExtDocuments}
<div>#{Id} - #{MeinWert}</div>
<div>#{Id} - #{MeinWert}</div>
#{ListEnd:ExtDocuments}
</body>
</html>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}