$re = '/[\n\r\s]*#{ListStart:ExtDocuments}[\n\r]([\w\n\r\s\<\>\#\{\}\/\-]*)#{ListEnd:ExtDocuments}[\n\r\s]*/';
$str = '<html>
<head>
<title>#{Subject}</title>
</head>
<body>
<div>StringTest: #{String}</div>
<div>IntTest: #{Int}</div>
<div>IntTest: #{INT}</div>
<div>IntTest: #{int}</div>
<div>IntTest: #{iNt}</div>
#{ListStart:Documents}
<div>#{Value}</div>
#{ListEnd:Documents}
#{ListStart:ExtDocuments}
<div>#{Id} - #{MeinWert}</div>
<div>#{Id} - #{MeinWert}</div>
#{ListEnd:ExtDocuments}
</body>
</html>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);