package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\n\r\s]*#{ListStart:ExtDocuments}[\n\r]([\w\n\r\s\<\>\#\{\}\/\-]*)#{ListEnd:ExtDocuments}[\n\r\s]*`)
var str = `<html>
<head>
<title>#{Subject}</title>
</head>
<body>
<div>StringTest: #{String}</div>
<div>IntTest: #{Int}</div>
<div>IntTest: #{INT}</div>
<div>IntTest: #{int}</div>
<div>IntTest: #{iNt}</div>
#{ListStart:Documents}
<div>#{Value}</div>
#{ListEnd:Documents}
#{ListStart:ExtDocuments}
<div>#{Id} - #{MeinWert}</div>
<div>#{Id} - #{MeinWert}</div>
#{ListEnd:ExtDocuments}
</body>
</html>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}